Newer
Older
Digital_Repository / OARiNZ / DIY / deb_package / eprints-3.0 / debian / rules
nstanger on 7 Jun 2007 2 KB - Added debian package source.
  1. #!/usr/bin/make -f
  2. # Sample debian/rules that uses debhelper.
  3. # This file is public domain software, originally written by Joey Hess.
  4. #
  5. # This version is for packages that are architecture independent.
  6.  
  7. # Uncomment this to turn on verbose mode.
  8. #export DH_VERBOSE=1
  9.  
  10. build: build-stamp
  11. build-stamp:
  12. dh_testdir
  13.  
  14. # Add here commands to compile the package.
  15. #$(MAKE)
  16. # Note that the configure script expects the eprints user and group to
  17. # exist before it is run. I couldn't figure out how to create the user
  18. # and group within the pbuilder chroot, so instead I've fallen back to
  19. # installing as user/group www-data, then fixing the user/group details
  20. # in the postinst script (this seems to be how other packages deal with
  21. # this). The SMTP server gets sorted out at the same time, using debconf
  22. # (assume localhost given that we depend on mail-transport-agent anyway).
  23.  
  24. ./configure --with-user=www-data --with-group=www-data \
  25. --with-smtp-server=localhost
  26.  
  27. touch build-stamp
  28.  
  29. clean:
  30. dh_testdir
  31. dh_testroot
  32. rm -f build-stamp
  33.  
  34. # Add here commands to clean up after the build process.
  35. #-$(MAKE) clean
  36. #-$(MAKE) distclean
  37. -rm config.log
  38. -rm config.status
  39. -rm install.pl
  40.  
  41. dh_clean
  42.  
  43. install: build
  44. dh_testdir
  45. dh_testroot
  46. dh_clean -k
  47. dh_installdirs
  48.  
  49. # Add here commands to install the package into debian/<packagename>.
  50. #$(MAKE) prefix=`pwd`/debian/`dh_listpackages`/usr install
  51. # Call install script with a path argument to override the default
  52. # installation prefix.
  53. ./install.pl $(CURDIR)/debian/`dh_listpackages`/opt/eprints3
  54.  
  55. # Build architecture-independent files here.
  56. binary-indep: build install
  57. dh_testdir
  58. dh_testroot
  59. dh_installchangelogs
  60. dh_installdocs
  61. # dh_installexamples
  62. # dh_installmenu
  63. # dh_installdebconf
  64. # dh_installlogrotate
  65. # dh_installemacsen
  66. # dh_installcatalogs
  67. # dh_installpam
  68. # dh_installmime
  69. dh_installinit --name=epindexer
  70. dh_installcron
  71. # dh_installinfo
  72. # dh_undocumented
  73. dh_installman
  74. dh_link
  75. dh_compress
  76. dh_fixperms
  77. # dh_perl
  78. # dh_python
  79. dh_installdeb
  80. dh_gencontrol
  81. dh_md5sums
  82. dh_builddeb
  83.  
  84. # Build architecture-dependent files here.
  85. binary-arch: build install
  86. # We have nothing to do by default.
  87.  
  88. binary: binary-indep binary-arch
  89. .PHONY: build clean binary-indep binary-arch binary install