Newer
Older
Digital_Repository / OARiNZ / DIY / webmin-oarinz / webmin-oarinz-1.340 / debian / rules
nstanger on 20 Jun 2007 1 KB - First working version.
  1. #!/usr/bin/make -f
  2. # -*- makefile -*-
  3. # Sample debian/rules that uses debhelper.
  4. # This file was originally written by Joey Hess and Craig Small.
  5. # As a special exception, when this file is copied by dh-make into a
  6. # dh-make output file, you may use that output file without restriction.
  7. # This special exception was added by Craig Small in version 0.37 of dh-make.
  8.  
  9. # Uncomment this to turn on verbose mode.
  10. #export DH_VERBOSE=1
  11.  
  12.  
  13. configure: configure-stamp
  14. configure-stamp:
  15. dh_testdir
  16. touch $@
  17.  
  18.  
  19. build: build-stamp
  20.  
  21. build-stamp: configure-stamp
  22. dh_testdir
  23. touch $@
  24.  
  25. clean:
  26. dh_testdir
  27. dh_testroot
  28. rm -f build-stamp configure-stamp
  29. dh_clean
  30.  
  31. install: build
  32. dh_testdir
  33. dh_testroot
  34. dh_clean -k
  35. dh_installdirs
  36. # Everything is set up in the postinst, so we just need to copy
  37. # the files into place here.
  38. find . -mindepth 1 -maxdepth 1 -type d \
  39. -and -not -name debian \
  40. -exec cp -a {} $(CURDIR)/debian/webmin-oarinz/usr/share/webmin \;
  41. find . -mindepth 1 -maxdepth 1 -type f \
  42. -and -not -name "*-stamp" \
  43. -exec cp -p {} $(CURDIR)/debian/webmin-oarinz/usr/share/webmin \;
  44.  
  45.  
  46. # Build architecture-independent files here.
  47. binary-indep: build install
  48. dh_testdir
  49. dh_testroot
  50. dh_installchangelogs
  51. dh_installdocs
  52. # dh_installexamples
  53. # dh_install
  54. # dh_installmenu
  55. # dh_installdebconf
  56. # dh_installlogrotate
  57. # dh_installemacsen
  58. # dh_installpam --name=webmin
  59. # dh_installmime
  60. # dh_python
  61. # dh_installinit
  62. # dh_installcron
  63. # dh_installinfo
  64. # dh_installman
  65. dh_link
  66. # dh_strip
  67. dh_compress
  68. dh_fixperms
  69. # dh_perl
  70. # dh_makeshlibs
  71. dh_installdeb
  72. # dh_shlibdeps
  73. dh_gencontrol
  74. dh_md5sums
  75. dh_builddeb
  76.  
  77. # Build architecture-dependent files here.
  78. binary-arch: build install
  79. # We have nothing to do by default.
  80.  
  81. binary: binary-indep binary-arch
  82. .PHONY: build clean binary-indep binary-arch binary install configure